package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w{2}-\w{2})/questions(?:/(\w+)){0,1}(?:/(\d+)){0,1}(?:/.*?)?$`)
var str = `en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}