const regex = new RegExp('^(\\w{2}-\\w{2})/questions(?:/(\\w+)){0,1}(?:/(\\d+)){0,1}(?:/.*?)?$', 'gm')
const str = `en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}