import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{2}-\\w{2})/questions(?:/(\\w+)){0,1}(?:/(\\d+)){0,1}(?:/.*?)?$";
final String string = "en-us/questions/ask\n"
+ "en-us/questions/newest/15\n"
+ "en-us/questions/12/just-a-text-to-be-ignored";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}