$re = '/^(\w{2}-\w{2})/questions(?:/(\w+)){0,1}(?:/(\d+)){0,1}(?:/.*?)?$/m';
$str = 'en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);