using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+?)=(.+?)(?=\s\w+=|$)";
string input = @"metadata=1 .2 name=sto\\= ne: s up ers hare UUID=eff4e7b c:47aea 5cf:0f0560f 0:2de3 8475";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}