$re = '/(\w+?)=(.+?)(?=\s\w+=|$)/';
$str = 'metadata=1 .2 name=sto\\\\= ne: s up ers hare UUID=eff4e7b c:47aea 5cf:0f0560f 0:2de3 8475';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);