const regex = /(\w+?)=(.+?)(?=\s\w+=|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+?)=(.+?)(?=\\s\\w+=|$)', 'g')
const str = `metadata=1 .2 name=sto\\\\= ne: s up ers hare UUID=eff4e7b c:47aea 5cf:0f0560f 0:2de3 8475`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}