use strict;
my $str = 'metadata=1 .2 name=sto\\\\= ne: s up ers hare UUID=eff4e7b c:47aea 5cf:0f0560f 0:2de3 8475';
my $regex = qr/(\w+?)=(.+?)(?=\s\w+=|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}