#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\.-)(?!(.{7})?$)"
Local $sString = "GRID 1 3268.616-30.0828749.8656 " & @CRLF & _
"GRID 2 3268.781 -3.-14749.8888" & @CRLF & _
"GRID 3 3422.488580.928382.49383" & @CRLF & _
"GRID 4 3422.488 10.-2.49383" & @CRLF & _
"GRID 5 3422.488 10.-342.49383" & @CRLF & _
"GRID 6 3422.-488 10.-342.4938"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")