# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\.-)(?!(.{7})?$)"
test_str = ("GRID 1 3268.616-30.0828749.8656 \n"
"GRID 2 3268.781 -3.-14749.8888\n"
"GRID 3 3422.488580.928382.49383\n"
"GRID 4 3422.488 10.-2.49383\n"
"GRID 5 3422.488 10.-342.49383\n"
"GRID 6 3422.-488 10.-342.4938")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.