import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.-)(?!(.{7})?$)";
final String string = "GRID 1 3268.616-30.0828749.8656 \n"
+ "GRID 2 3268.781 -3.-14749.8888\n"
+ "GRID 3 3422.488580.928382.49383\n"
+ "GRID 4 3422.488 10.-2.49383\n"
+ "GRID 5 3422.488 10.-342.49383\n"
+ "GRID 6 3422.-488 10.-342.4938";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}