re = /(\.-)(?!(.{7})?$)/m
str = 'GRID 1 3268.616-30.0828749.8656
GRID 2 3268.781 -3.-14749.8888
GRID 3 3422.488580.928382.49383
GRID 4 3422.488 10.-2.49383
GRID 5 3422.488 10.-342.49383
GRID 6 3422.-488 10.-342.4938'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end