const regex = /\[\s*\*?\s*(.*?)\s*?\*?\s*\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s*\\*?\\s*(.*?)\\s*?\\*?\\s*\\]', 'g')
const str = `[* content I want *]
[ some more content ]
[ lol this is moar content]
[ spaces and formatting things * ]
[*** multiple asterisks WILL BE CONSUMED ]
[ go ahead ]
[ * look right at "match information", you will see everything correctly matched * ]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}