import re
regex = re.compile(r"\[\s*\*?\s*(.*?)\s*?\*?\s*\]")
test_str = ("[* content I want *]\n"
"[ some more content ]\n"
"[ lol this is moar content]\n"
" [ spaces and formatting things * ]\n"
"[*** multiple asterisks WILL BE CONSUMED ]\n"
"[ go ahead ]\n"
"[ * look right at \"match information\", you will see everything correctly matched * ]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")