// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\s*\*?\s*(.*?)\s*?\*?\s*\]").unwrap();
let string = "[* content I want *]
[ some more content ]
[ lol this is moar content]
[ spaces and formatting things * ]
[*** multiple asterisks WILL BE CONSUMED ]
[ go ahead ]
[ * look right at \"match information\", you will see everything correctly matched * ]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}