$re = '/\[\s*\*?\s*(.*?)\s*?\*?\s*\]/';
$str = '[* content I want *]
[ some more content ]
[ lol this is moar content]
[ spaces and formatting things * ]
[*** multiple asterisks WILL BE CONSUMED ]
[ go ahead ]
[ * look right at "match information", you will see everything correctly matched * ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);