import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@import (url\\(\\\"?)?(url\\()?(\\\")?(.*?)(?(1)\\\")+(?(2)\\))+(?(3)\\\")";
final String string = "@import url(comments.css);\n"
+ "body{\n"
+ " margin: 0px;\n"
+ " padding: 0px;\n"
+ " background: #FFFFFF;\n"
+ " font: normal small \"Trebuchet MS\", Arial, Helvetica, sans-serif;\n"
+ " color: #777777;\n"
+ "}\n"
+ "@import \"/style/main.css\" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */\n"
+ "@import \"/style/palm.css\" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *\n\n"
+ "@import url(\"style-1024.css\") screen and (min-width: 1000px) and (max-width: 1279px);\n"
+ "@import url(\"style-1280.css\") screen and (min-width: 1280px) and (max-width: 1300px);\n"
+ "@import url(\"style-1366.css\") screen and (min-width: 1301px) and (max-width: 1900px);\n"
+ "@import url(\"style-1366.css\") screen and (min-width: 1901px);";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}