const regex = /@import (url\(\"?)?(url\()?(\")?(.*?)(?(1)\")+(?(2)\))+(?(3)\")/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@import (url\\(\\"?)?(url\\()?(\\")?(.*?)(?(1)\\")+(?(2)\\))+(?(3)\\")', 'ig')
const str = `@import url(comments.css);
body{
margin: 0px;
padding: 0px;
background: #FFFFFF;
font: normal small "Trebuchet MS", Arial, Helvetica, sans-serif;
color: #777777;
}
@import "/style/main.css" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */
@import "/style/palm.css" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *
@import url("style-1024.css") screen and (min-width: 1000px) and (max-width: 1279px);
@import url("style-1280.css") screen and (min-width: 1280px) and (max-width: 1300px);
@import url("style-1366.css") screen and (min-width: 1301px) and (max-width: 1900px);
@import url("style-1366.css") screen and (min-width: 1901px);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}