import re
regex = re.compile(r"@import (url\(\"?)?(url\()?(\")?(.*?)(?(1)\")+(?(2)\))+(?(3)\")", flags=re.IGNORECASE)
test_str = ("@import url(comments.css);\n"
"body{\n"
" margin: 0px;\n"
" padding: 0px;\n"
" background: #FFFFFF;\n"
" font: normal small \"Trebuchet MS\", Arial, Helvetica, sans-serif;\n"
" color: #777777;\n"
"}\n"
"@import \"/style/main.css\" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */\n"
"@import \"/style/palm.css\" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *\n\n"
"@import url(\"style-1024.css\") screen and (min-width: 1000px) and (max-width: 1279px);\n"
"@import url(\"style-1280.css\") screen and (min-width: 1280px) and (max-width: 1300px);\n"
"@import url(\"style-1366.css\") screen and (min-width: 1301px) and (max-width: 1900px);\n"
"@import url(\"style-1366.css\") screen and (min-width: 1901px);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")