// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)@import (url\(\"?)?(url\()?(\")?(.*?)(?(1)\")+(?(2)\))+(?(3)\")"#).unwrap();
let string = "@import url(comments.css);
body{
margin: 0px;
padding: 0px;
background: #FFFFFF;
font: normal small \"Trebuchet MS\", Arial, Helvetica, sans-serif;
color: #777777;
}
@import \"/style/main.css\" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */
@import \"/style/palm.css\" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *
@import url(\"style-1024.css\") screen and (min-width: 1000px) and (max-width: 1279px);
@import url(\"style-1280.css\") screen and (min-width: 1280px) and (max-width: 1300px);
@import url(\"style-1366.css\") screen and (min-width: 1301px) and (max-width: 1900px);
@import url(\"style-1366.css\") screen and (min-width: 1901px);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}