#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((091|\+91)?|\((091|\+91)?\)|(91)?|\(91\)|0)? ?[7-9][0-9]{9}$"
Local $sString = "+91 7990989898" & @CRLF & _
"91 7990989898" & @CRLF & _
"091 7990989898" & @CRLF & _
"0 7990989898" & @CRLF & _
"(0+91)7990989898" & @CRLF & _
"+7990989898" & @CRLF & _
"0(+91) 7990989898" & @CRLF & _
"0(91) 7990989898" & @CRLF & _
"7990989898" & @CRLF & _
"+917990989898" & @CRLF & _
"917990989898" & @CRLF & _
"07990989898" & @CRLF & _
"0917990989898" & @CRLF & _
"(91)7990989898" & @CRLF & _
"(+91)7990989898" & @CRLF & _
"(91) 7990989898" & @CRLF & _
"(+91) 7990989898" & @CRLF & _
"(091) 7990989898" & @CRLF & _
"(091)7990989898" & @CRLF & _
"0+91 7990989898"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")