using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((091|\+91)?|\((091|\+91)?\)|(91)?|\(91\)|0)? ?[7-9][0-9]{9}$";
string input = @"+91 7990989898
91 7990989898
091 7990989898
0 7990989898
(0+91)7990989898
+7990989898
0(+91) 7990989898
0(91) 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898
(91)7990989898
(+91)7990989898
(91) 7990989898
(+91) 7990989898
(091) 7990989898
(091)7990989898
0+91 7990989898";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}