import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((091|\\+91)?|\\((091|\\+91)?\\)|(91)?|\\(91\\)|0)? ?[7-9][0-9]{9}$";
final String string = "+91 7990989898\n"
+ "91 7990989898\n"
+ "091 7990989898\n"
+ "0 7990989898\n"
+ "(0+91)7990989898\n"
+ "+7990989898\n"
+ "0(+91) 7990989898\n"
+ "0(91) 7990989898\n"
+ "7990989898\n"
+ "+917990989898\n"
+ "917990989898\n"
+ "07990989898\n"
+ "0917990989898\n"
+ "(91)7990989898\n"
+ "(+91)7990989898\n"
+ "(91) 7990989898\n"
+ "(+91) 7990989898\n"
+ "(091) 7990989898\n"
+ "(091)7990989898\n"
+ "0+91 7990989898";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}