// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((091|\+91)?|\((091|\+91)?\)|(91)?|\(91\)|0)? ?[7-9][0-9]{9}$").unwrap();
let string = "+91 7990989898
91 7990989898
091 7990989898
0 7990989898
(0+91)7990989898
+7990989898
0(+91) 7990989898
0(91) 7990989898
7990989898
+917990989898
917990989898
07990989898
0917990989898
(91)7990989898
(+91)7990989898
(91) 7990989898
(+91) 7990989898
(091) 7990989898
(091)7990989898
0+91 7990989898";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}