package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.-?[_a-zA-Z]+[_a-zA-Z0-9-]*)`)
var str = `.myClass{color:red;}
.myClass .myOtherClass{color:green;}
#something .somethingElse{color:blue;}
.something #myIdhere{color:purple;}
#myId {color:black}
.myClass1, .myClass2{colour:green}
.menu_tab span{colour:purple}
.myPseudo:after{}
.-moz-special, .-ms-special{}
.4not2work{}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}