# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\.-?[_a-zA-Z]+[_a-zA-Z0-9-]*)"
test_str = (".myClass{color:red;}\n"
".myClass .myOtherClass{color:green;}\n"
"#something .somethingElse{color:blue;}\n"
".something #myIdhere{color:purple;}\n"
"#myId {color:black}\n"
".myClass1, .myClass2{colour:green}\n"
".menu_tab span{colour:purple}\n"
".myPseudo:after{}\n"
".-moz-special, .-ms-special{}\n"
".4not2work{}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.