re = /(\.-?[_a-zA-Z]+[_a-zA-Z0-9-]*)/
str = '.myClass{color:red;}
.myClass .myOtherClass{color:green;}
#something .somethingElse{color:blue;}
.something #myIdhere{color:purple;}
#myId {color:black}
.myClass1, .myClass2{colour:green}
.menu_tab span{colour:purple}
.myPseudo:after{}
.-moz-special, .-ms-special{}
.4not2work{}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end