#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^.]*(?=(?:\.[^.]*){3}$)"
Local $sString = "aa.bb.cc.dd.ee.xx"
Local $sSubst = "NN"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)