using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^.]*(?=(?:\.[^.]*){3}$)";
string substitution = @"NN";
string input = @"aa.bb.cc.dd.ee.xx";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}