$re = '/[^.]*(?=(?:\.[^.]*){3}$)/';
$str = 'aa.bb.cc.dd.ee.xx';
$subst = "NN";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;