import re
regex = re.compile(r"[^.]*(?=(?:\.[^.]*){3}$)")
test_str = "aa.bb.cc.dd.ee.xx"
subst = "NN"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)