import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "5+6\n\n\n\n";
final String string = "{'present_power_reading': (246, 'Watts'), 'average_power_reading': (241, 'Watts'), 'maximum_power_reading': (302, 'Watts'), 'minimum_power_reading': (227, 'Watts')}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}