// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)5+6
").unwrap();
let string = "{'present_power_reading': (246, 'Watts'), 'average_power_reading': (241, 'Watts'), 'maximum_power_reading': (302, 'Watts'), 'minimum_power_reading': (227, 'Watts')}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}