using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ap]\.m\.(*SKIP)(*FAIL)|\.";
string input = @"Applicants can check the final result of Admissions through the online enquiry system. The online enquiry system will be available from 10:00 a.m. on November 16 (Wednesday).";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}