const regex = /[ap]\.m\.(*SKIP)(*FAIL)|\./gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ap]\\.m\\.(*SKIP)(*FAIL)|\\.', 'gi')
const str = `Applicants can check the final result of Admissions through the online enquiry system. The online enquiry system will be available from 10:00 a.m. on November 16 (Wednesday).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}