package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[ap]\.m\.(*SKIP)(*FAIL)|\.`)
var str = `Applicants can check the final result of Admissions through the online enquiry system. The online enquiry system will be available from 10:00 a.m. on November 16 (Wednesday).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}