re = /[ap]\.m\.(*SKIP)(*FAIL)|\./i
str = 'Applicants can check the final result of Admissions through the online enquiry system. The online enquiry system will be available from 10:00 a.m. on November 16 (Wednesday).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end