using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$";
        string input = @"a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM";
        
        Match m = Regex.Match(input, pattern);
        Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
    }
}