re = /^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$/
str = 'a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM'
# Print the match result
str.match(re) do |match|
    puts match.to_s
end