// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$").unwrap();
  let string = "a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}