import Foundation
let pattern = #"^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}