using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?),([A-z]{2})$";
string input = @"New York,NY
San-Francisco
San Fran Cisco
Chicago
Chicago, IL
San-, CA
Norfolk
Norfolk, VA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}