import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?),([A-z]{2})$";
final String string = "New York,NY\n"
+ "San-Francisco\n"
+ "San Fran Cisco\n"
+ "Chicago\n"
+ "Chicago, IL\n"
+ "San-, CA\n"
+ "Norfolk\n"
+ "Norfolk, VA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}