re = /^(.+?),([A-z]{2})$/m
str = 'New York,NY
San-Francisco
San Fran Cisco
Chicago
Chicago, IL
San-, CA
Norfolk
Norfolk, VA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end