$re = '/^(.+?),([A-z]{2})$/m';
$str = 'New York,NY
San-Francisco
San Fran Cisco
Chicago
Chicago, IL
San-, CA
Norfolk
Norfolk, VA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);