using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[begin-match\]((?:(?!\[end-match\]).)*)\[end-match\]";
string input = @"This is [begin-match] a sample text [end-match] with some [begin-match] tokens and normal [end-match] text.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}