const regex = /\[begin-match\]((?:(?!\[end-match\]).)*)\[end-match\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[begin-match\\]((?:(?!\\[end-match\\]).)*)\\[end-match\\]', 'gm')
const str = `This is [begin-match] a sample text [end-match] with some [begin-match] tokens and normal [end-match] text.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}