re = /\[begin-match\]((?:(?!\[end-match\]).)*)\[end-match\]/m
str = 'This is [begin-match] a sample text [end-match] with some [begin-match] tokens and normal [end-match] text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end