$re = '/\[begin-match\]((?:(?!\[end-match\]).)*)\[end-match\]/m';
$str = 'This is [begin-match] a sample text [end-match] with some [begin-match] tokens and normal [end-match] text.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);