#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d+(?=[^(]*\))"
Local $sString = "Test123(45)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)